[gold-users] Incomplete web interface

Crusan, Steve scrusan at UR.Rochester.edu
Mon Jun 7 12:23:18 MDT 2010


Scott,

	The script alias was the issue, (reading directions generally
does help), but I was reluctant to change it since I had some other apps
running on the server. I just setup a dedicated dev server for gold, and
that fixed it.

	The only issue I'm having now is with the accounting section
part of the web interface. I cannot list user accounts, modify or delete
them (via the Web GUI anyway). 

	I get the following error from the web interface:

<script type="text/javascript">//<![CDATA[
  var searchValues = new Array();

  function updateStatus(statusInfo) {
    if (statusInfo)
    {
      parent.statusbar.document.location="status.cgi?" + statusInfo;
    }
  }

//]]></script>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"
/>
</head>
<body onload="updateStatus(&quot;message=DBD::Pg::st execute failed:
ERROR:  syntax error at or near &quot;'g_a_n_y'&quot; at character 44
&quot;)">

</body>
</html>



Looking at the gold logs, I get the following:

SQL Query: SELECT g_account.g_id AS g_id,'g_a_n_y' AS 'g_a_n_y','g_a_n_
y' AS 'g_a_n_y','g_a_n_y' AS 'g_a_n_y' FROM g_account WHERE (  (
g_account.g_id!='0' AND g_account.g_id!='0' )  ) AND g_delet
ed!='True'
2010-06-07 14:04:40.072 TRACE Gold::Response::new  invoked with
arguments: ()
2010-06-07 14:04:40.072 TRACE Gold::Response::failure  invoked with
arguments: (720, DBD::Pg::st execute failed: ERROR:  syntax error at or
near "'g_a_n_y'" at character 44



Looking at the SELECT statement, it obv doesn't work when I connect to
the DB and run it manually. I'm guessing the query is created from a few
env variables such as the username that's connection to the web
interface and such, but this happens no matter what user I use. 

I this an error with my setup again? Everything else works well...


 
-----------------------------------------------
Steve Crusan
System Administrator
Center for Research Computing
University of Rochester
(716) 239 - 0962
-----Original Message-----
From: Scott Jackson [mailto:scottmo at adaptivecomputing.com] 
Sent: Friday, June 04, 2010 5:51 PM
To: Crusan, Steve
Cc: gold-users at supercluster.org
Subject: Re: [gold-users] Incomplete web interface

Steve,

I am not certain from your description of things. Perhaps you need to 
change ScriptAlias to Alias (removing all cgi-bin ScriptAlias entries) 
in your httpd.conf files. Perhaps it is a role issue (have you 
configured it so Anonymous can only see Users?). Have you restarted 
goldd (sometimes gchpassword or role changes do not take until a 
restart). If none of these seem to work, please send a screenshot of 
what you are seeing.

Thanks,

Scott


Steve Crusan wrote:
>
> Greetings,
>
>
> I have installed gold (newest version in tree), setup it up, and ran 
> run jobs and allocate funds w/ Maui/torque. Now, using the command 
> line (as the gold user), I can view these statistics just fine.
>
> I can login to the web interface (as gold), but I only can see the 
> users administration pane. I cannot open any of the other navigation 
> panels, etc. Is there something else I need to enable and such, or is 
> there a script that isn't working?
>
> Sorry if this is a dumb question...
>
> ----------------------
> Steve Crusan
> System Administrator
> Center for Research Computing
> University of Rochester
> (716) 239 - 0962
>
------------------------------------------------------------------------
>
> _______________________________________________
> gold-users mailing list
> gold-users at supercluster.org
> http://www.supercluster.org/mailman/listinfo/gold-users
>   


More information about the gold-users mailing list