[gold-users] Installation prerequisites

Scott Jackson scottmo at clusterresources.com
Wed Jun 10 15:19:30 MDT 2009


Ken,

Interesting. It was my belief that the steps that you describe having 
taken should have been just right. It is intended that the user who you 
run configure as becomes the "gold" user and all permissions should be 
set accordingly. I did not believe that there were any problems where it 
would fallback to using the literal user gold unless overridden with the 
configure --with-user=gold option. Apparently I am mistaken.

Let's explore where things went wrong. As you specified, it should have 
gleaned the correct user from the id of the user that you ran configure 
as. This should have been put in the Makefile as USER = goldam.

Can you give me the result of the following:

grep "^USER" Makefile

Later, when you run make install, it should have used this user:

install:
    -mkdir -p $(build_root)$(prefix) && chown $(USER) $(build_root)$(prefix)
    -mkdir $(libdir) && chown $(USER) $(libdir)
    -mkdir $(libdir)/Gold && chown $(USER) $(libdir)/Gold && chmod 755 
$(libdir)/Gold
    -mkdir $(sbindir) && chown $(USER) $(sbindir)
    -mkdir $(bindir) && chown $(USER) $(bindir)
    -mkdir $(sysconfdir) && chown $(USER) $(sysconfdir)
    -mkdir $(docdir) && chown $(USER) $(docdir)
    -mkdir $(logdir) && chown $(USER) $(logdir) && chmod 777 $(logdir)
    -[ "$(DB_TYPE)" = "SQLite" ] && mkdir $(datadir) && chown $(USER) 
$(datadir) && chmod 777 $(datadir)
...
    cp $(BINS) $(bindir) && \
        (cd $(bindir)/.. && chown $(USER) $(BINS) && chmod 4755 $(BINS))
    cp $(WRAPPERS) $(bindir) && \
        (cd $(bindir)/.. && chown $(USER) $(WRAPPERS) && chmod 755 
$(WRAPPERS))
    cp $(SBINS) $(sbindir) && \
        (cd $(sbindir)/.. && chown $(USER) $(SBINS))
    for file in $(DOCS); do \
        cp doc/$${file}.pdf $(docdir) && chown $(USER) 
$(docdir)/$${file}.pdf; \
        cp -r doc/$$file $(docdir) && chown -R $(USER) $(docdir)/$$file; \
    done
    [ -s $(sysconfdir)/gold.conf ] || \
        (cp etc/gold.conf.dist $(sysconfdir)/gold.conf && \
        chown $(USER) $(sysconfdir)/gold.conf)
    [ -s $(sysconfdir)/goldd.conf ] || \
        (cp etc/goldd.conf.dist $(sysconfdir)/goldd.conf && \
        chown $(USER) $(sysconfdir)/goldd.conf && \
        chmod 600 $(sysconfdir)/goldd.conf)

This should have also taken affect for the auth_key target:

auth_key:
    @echo -n "Enter your secret key (up to 80 characters and can include 
spaces): "
    @read key && echo $$key >>$(sysconfdir)/auth_key && \
        chown $(USER) $(sysconfdir)/auth_key && chmod 400 
$(sysconfdir)/auth_key

I currently cannot explain the behavior you saw. Please start by giving 
me the requested output and then a full listing of the permissions of 
the installed files.

Thanks,

Scott



Ken Schumacher wrote:
> Thanks Scott,
>
> I think I have found another point worth mentioning.
>
> I went through the installation document working the steps as I went 
> along.  Had I read the whole thing first and then ran through the 
> steps, this might have turned out differently.
>
> I created a new user on my system to be the non-root owner of this 
> software installation.  I picked the name 'goldam' and gave it a 
> unique UID on my host.  I used an existing group called 'products' 
> which we use around here.  Most of our systems admins are members of 
> the products group.  This allows read access to config files and such.
>
> When I ran the initial configure and make steps, I did so as user 
> 'goldam'.  I used the defaults as much as possible and specified very 
> little as options to configure and make.  I saw that the default was 
> to make the software as the user that ran the make command.  So most 
> of the software is owned by user 'goldam' and group 'products', as I 
> intended.
>
> Then I ran the make steps which must be run as user 'root'.  For 
> these, it appears that files that were installed in those steps are 
> owned by user 'gold' (which I had not created on the system) and group 
> 'root'.  I discovered this when I got to the step where I am supposed 
> to edit the goldd.conf file.  I would have expected that the 'goldam' 
> user would have been set as the default when I ran configure under 
> that account.  But it appears that username was not saved in the 
> configuration.  Then when I ran the later steps as root, it used the 
> 'gold' username as the default.
>
> So I assume I need to re-run the configure and specifically tell it I 
> want to use the 'goldam' username and then remake things.  Hopefully, 
> that will correct the ownerships and then I will be able to edit the 
> configuration files without having to log in as 'root' to do so.
>
> If I am off-base here, please let me know.
>
> More later,
> Ken S.
>
>
> On Jun 10, 2009, at 12:49 PM, Scott Jackson wrote:
>
>> Ken,
>>
>> I have looked at this and clearly you are right. The problem now is 
>> what should it say. I am trying to figure out what minimal version I 
>> should have said it pertained to. I do not see any reason that 2.0.26 
>> is all that special. I have looked and cannot even find an old rpm 
>> based on anything earlier than 2.0.44. I'm not sure there is anything 
>> terribly wrong with any version of 2.0 and higher (I believe this is 
>> needed to interoperate with apache 2.0 and higher). So I will change 
>> the INSTALL to say:
>>
>> Index: INSTALL.in
>> ===================================================================
>> --- INSTALL.in  (revision 114)
>> +++ INSTALL.in  (working copy)
>> @@ -142,7 +142,7 @@
>>    [root]  wget 
>> http://rpm.emsl.pnl.gov/3.0AW/en/os/i386-U4/RedHat/RPMS/openssl-0.9.7a-33.12.i386.rpm 
>>
>>    [root]  rpm -Uvh openssl-0.9.7a-33.12.i386.rpm
>> -  o mod_ssl 2.26 or higher [OPTIONAL]:
>> +  o mod_ssl 2.0 or higher [OPTIONAL]:
>>    -----------------------------------------------
>>    If you are installing the gui you will need an apache interface to 
>> OpenSSL
>>
>>
>> Thanks for pointing this out.
>>
>> Scott
>>
>>
>> Ken Schumacher wrote:
>>> Greetings,
>>>
>>> I'm installing my first installation of the Gold Allocation 
>>> Manager.   I am working through the documentation and I believe I 
>>> have come  across a typo.
>>>
>>> http://www.clusterresources.com/products/gold/docs/userguide/x187.html
>>>
>>> The last package listed is "mod_ssl 2.26 or higher [OPTIONAL]".  
>>> The  short section that follows lists a wget of  
>>> mod_ssl-2.0.46-44.ent.i386.rpm.  I checked the system I am 
>>> installing  on and it already has mod_ssl-2.0.52-41.sl4.2.i386 
>>> installed.
>>>
>>> I expect my system meets this prerequisite.  I believe this 
>>> subheading  should read "2.0.26 or higher" and that I have simply 
>>> discovered a  typo.  If I am missing something here, please let me 
>>> know.
>>>
>>> I suppose I should ask if there is a more appropriate place for me 
>>> to  report typos and/or seek clarifications like this.
>>>
>>> More later,
>>> Ken S.
>>>
>>> = = = 
>>> ======================================================================== 
>>>
>>> Ken Schumacher   <kschu at fnal.gov>  (o) 630-840-4579 (f) 630-840-3109
>>> Computing Div/HPC  LQCD Group   Loc: WH8E   http://www.usqcd.org/fnal/
>>> Fermi National Accelerator Lab; PO Box 500 MS 120 Batavia, IL 
>>> 60510-0500
>>>
>>>
>>>
>>> _______________________________________________
>>> gold-users mailing list
>>> gold-users at supercluster.org
>>> http://www.supercluster.org/mailman/listinfo/gold-users
>>>
>>
>
> ==============================================================
> Ken Schumacher  <kschu at fnal.gov>  (o) 630-840-4579 (f) 630-840-3109
> Computing Div/HPC  LQCD Group   Loc: WH8E   http://www.usqcd.org/fnal/
> Fermi National Accelerator Lab; PO Box 500 MS 120 Batavia, IL 60510-0500
>
>
>
>
>
>
>



More information about the gold-users mailing list