Bug 38 - Torque can't handle email addresses with apostrophes
: Torque can't handle email addresses with apostrophes
Product: TORQUE
: 2.3.x
: Other Linux
: P5 enhancement
Assigned To: Glen
  Show dependency treegraph
Reported: 2009-12-02 15:44 MST by Chris Samuel
Modified: 2011-03-12 18:09 MST (History)
3 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Chris Samuel 2009-12-02 15:44:32 MST
 * Originally submitted to torquedev and torqueusers list
 * 11th December 2008.
 * Same issue in current 2.3.x of Torque, no way of testing
 * 2.4.x yet but I suspect the bug is still there.

A user who has an email address with an apostrophe (')
in it was trying to submit jobs and getting the following
rather cryptic error:

$ qsub test.sh
qsub: unmatched

This is because Torque constructs a fake command line
from all the #PBS lines in your script.  It then parses
the list to check you don't have any unmatched quotes
in it and throws that error..

Problem is that ' is perfectly legal in an email address.

I've tried escaping the ' as \' and jobs get submitted,
but then the emails to the user that they've requested
never get sent or received.
Comment 1 Glen 2010-01-03 21:32:56 MST

If we can get this to work with the apostrophe escaped or with the email
address enclosed in double quotes would that be OK?  I've got someone looking
at this.

At first I thought it would be nice if it just worked in the job script without
having to escape anything, but when entered on the command line it has to be
escaped or quoted, so I think the first thing we should do is get it working
when the apostrophe is escaped or the email address is enclosed in double
quotes.  Then it might be nice to see if we can make it work in the job script
without having to escape.
Comment 2 Chris Samuel 2010-01-05 15:37:42 MST
Hi Glen,

Escaping or double quotes would be fine!

Comment 3 Lev Lafayette 2010-01-05 16:31:52 MST
Just a quick note that I'm adding myself to the cc list for this bug.

Regards, Lev
Comment 4 Chris Samuel 2010-01-06 18:57:46 MST
Glen, could you transfer ownership of this bug to Lev please ?
Comment 5 Glen 2010-01-06 19:29:54 MST
I don't seem to have permission to do that
Comment 6 Chris Samuel 2010-01-06 19:52:16 MST
That's OK - I actually meant reporter not owner.. ;-)
Comment 7 Lev Lafayette 2010-09-14 19:03:54 MDT
I just tested this and it seems that it is still an issue...
Comment 8 David Beer 2011-03-01 10:08:20 MST
The fix for this has now been checked in to 2.4 and 2.5. The fix is in the
2.5.5 release candidate, and the 2.4 fix can be found here: