Bug 214 - qsub weird behavior when using filter script
: qsub weird behavior when using filter script
Status: RESOLVED FIXED
Product: TORQUE
clients
: 2.5.x
: All Linux
: P5 major
Assigned To: Ken Nielson
:
:
:
  Show dependency treegraph
 
Reported: 2012-08-13 07:57 MDT by tgray26
Modified: 2012-08-16 16:06 MDT (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description tgray26 2012-08-13 07:57:36 MDT
When using a filter script I've found that qsub will not honor the resource
list if the -I (interactive) flag appears before the -l (resource list) in the
arguments. I.E. if I have a filter (even with just #!/bin/bash and nothing
else) and I run "qsub -I -l mem=12GB" I will get the queue defaults instead of
12GB, but if I run "qsub -l mem=12GB -I" I will get the 12GB.
Comment 1 Chris Samuel 2012-08-13 19:03:27 MDT
That appears to be a regression in 2.5 from 2.4 then as it works OK here.
Comment 2 tgray26 2012-08-16 16:06:01 MDT
This behavior was being exhibited in 2.5.8, but I just upgraded one of our
clusters to 2.5.12 and the problem was gone. Looking in the change logs I
believe this was fixed in 2.5.10 by this change:

b - Removed a check for Interactive jobs in qsub and the -l flag. This check 
      appeared to be code that was never completed and it prevented the passing 
      of resource arguments.