Bug 196 - tcp.h not installed
: tcp.h not installed
Status: RESOLVED FIXED
Product: TORQUE
clients
: 4.0.*
: PC Linux
: P5 minor
Assigned To: David Beer
:
:
:
  Show dependency treegraph
 
Reported: 2012-05-16 19:35 MDT by Martin Siegert
Modified: 2012-05-29 10:02 MDT (History)
2 users (show)

See Also:


Attachments
Fix (704 bytes, patch)
2012-05-17 09:11 MDT, David Beer
Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description Martin Siegert 2012-05-16 19:35:37 MDT
When compiling an application that uses the TM interface, i.e., includes tm.h,
the compilation fails because tcp.h is not found: e.g. installing torque-4.0.2
to /usr/local/torque the /usr/local/torque/include directory contains tm.h but
not tcp.h - configure ----with-tm=/usr/local/torque ... of openmpi fails with:

--- MCA component ess:tm (m4 configuration macro)
checking for MCA component ess:tm compile mode... dso
checking --with-tm value... sanity check ok (/usr/local/torque-4.0.2)
checking for pbs-config... /usr/local/torque-4.0.2/bin/pbs-config
checking tm.h usability... no
checking tm.h presence... no
checking for tm.h... no
checking tm.h usability... no
checking tm.h presence... no
checking for tm.h... no
configure: error: TM support requested but not found.  Aborting
Comment 1 David Beer 2012-05-17 09:11:18 MDT
Created an attachment (id=108) [details]
Fix

The attached patch should fix the problem. Can you verify the fix for me
Martin?
Comment 2 David Beer 2012-05-17 09:23:36 MDT
I forgot to mention - you will have to run autogen.sh again after applying that
patch. It can be applied:

patch -p0 < Dist.patch 

from the directory containing src/
Comment 3 Martin Siegert 2012-05-22 18:22:10 MDT
I applied the patch and ran ./autogen.sh, but configure fails instantly with

configure: error: cannot find macro directory `m4'

Apparently this is due to the version of libtoolize on SL-5.6 (libtool-1.5.22).
Thus, I ran autogen.sh on opensuse-12.1. This generated the following warning
from aclocal (the same also from autoconf -f and autoheader -f):

configure.ac:674: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in
body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
acinclude.m4:156: TAC_SYS_LARGEFILE is expanded from...
configure.ac:674: the top level

and then a lot of errors from automake -a -c -f about missing test directories
(from, e.g., src/lib/Libattr/Makefile.am, line 4) and configure.ac, line 114:
configure.ac:114: required file `src/cmds/test/Makefile.in' not found
etc.

After that the file src/include/Makefile.in remained unchanged, i.e.,
include_HEADERS still does not contain tcp.h whereas noinst_HEADERS still
does.
Comment 4 David Beer 2012-05-29 10:02:37 MDT
I was able to reproduce and fix this issue, and this will be included in the
4.0.3 release.