Bug 140 - RPM spec files not being updated with configure options.
: RPM spec files not being updated with configure options.
Status: RESOLVED INVALID
Product: TORQUE
clients
: 2.5.x
: PC Linux
: P5 normal
Assigned To: Ken Nielson
:
:
:
  Show dependency treegraph
 
Reported: 2011-06-28 08:22 MDT by Dan Croft
Modified: 2011-07-05 17:53 MDT (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dan Croft 2011-06-28 08:22:00 MDT
1 - ./configure --prefix=/bin/blah
2 - make rpm
3 - rpm -ql -p /<path>/<to>/torque-2.5.5-1.cri.x86_64.rpm

configuration options are not being passed down to the rpm spec files before
they are being built. 

This is misleading as you can supply the correct options to TORQUE to build it
on exotic architecture (ALtix,UV) only to have it fail.
Comment 1 Michael Jennings 2011-07-05 17:53:55 MDT
This is by design and is not a bug.  Please see the explanation here:

http://blog.gmane.org/gmane.comp.clustering.torque.user/day=20110406

Additional rpmbuild options can be supplied to "make rpm" using the RPMOPTS
variable.